问题描述
登录网页版邮箱,提示“当前邮箱域名配置了与MX解析冲突的CNAME解析,可能导致部分邮件无法收到,请及时联系管理员检查并按要求修改(该提示将在解析生效后的1~2小时内自动消失)”。
问题原因
通过CNAME的方式接入了其他产品,如ECS,CDN等。
可能出现与MX解析冲突,导致收不到邮件。
解决方案
不要同时使用主机记录为@的 CNAME和@的 MX。
三种操作方式选择一种:
1、目前只有localDNS缓存才会出现解析到CNAME,导致找不到MX,观察是否有漏信情况。
2、使用其他域名或子域名购买邮箱。
3、邮箱域名移除CNAME,使用www代替@或使用A记录,接入ECS,CDN等其他产品。
重要
操作前请评估是否在使用该CNAME记录,以免移除后影响业务。